Martin Lantzsch
Software Entwickler
9. Juli 2012

Finger weg vom Vodafone LTE

9. Juli 2012 - Geschrieben von Martin - 2 Kommentare

Vor zwei Wochen waren bei mir zwei Typen von Vodafone mit einem Testrouter, nachdem ich ja letztes Jahr bereits an einem Test teilgenommen habe und ich nicht sonderlich begeistert war.

Diesmal haben sie teilweise ganze 6MBit herausbekommen und meinten dass natürlich noch mehr möglich sei, wenn ich den Router ordentlich ausrichte und ihn eine Zeit lang laufen habe, denn das Synchronisiert er sich. Gut dachte ich mir okay, dann holste dir halt mal eine 30 Tage Teststellung. Denn diesmal wurde mir versprochen und vertraglich festgehalten, dass es keine Volumenbegrenzung gibt (d.h. Drosselung ab X GB Traffic).

Nach einer Woche kam dann eine EasyBox und eine LTEBox. Ersteres ist der Router, zweiteres das LTE Modem, dass als eine Art Gateway fungiert. Beides zusammengestöpselt ging es auch Out of the Box los.

Natürlich gleich mal einen Speedtest gemacht, dieser fiel mit 600kbit/s allerdings nicht ganz so berauschend aus. Gut, dann gleich nochmal einen. Diesmal 1200kbit/s und beim dritten sogar 3000kb/s. Nach zwei drei Minuten habe ich dann noch mal einen gemacht und nun hing ich bei 80kbit/s. Was war geschehen? Ich habe den Router nicht bewegt, das Wetter blieb gleich und sogar das Fenster stand genau so offen wie zuvor.

Mehrere Stunden testen ergaben immer extreme Schwankungen in der Bandbreite. Mal kann ich ein YouTube Video in Full HD ohne Ladezeit anschauen, 10 Sekunden später komme ich nicht mal mehr auf Google. Umstellen des Routers im ganzen Haus, vom Erdgeschossen über den Garten bis in Dachboden haben nichts gebracht. Immer sehr instabil.

Ab dem dritten Tag fing dann der Router zu spacken an, mal geht das WLan, dann wieder nicht. Abhilfe schafft nur blödes herumklicken auf dem Admin Frontend, denn das scheint übelst verbuggt zu sein, denn Einstellungen werden oftmals nicht gespeichert.

Nach nun einer Woche habe ich es echt satt. Meine DSL Lite Leitung ist um einiges stabiles als dieser Dreck. Meine Nachbarn, denen das LTE genau so angedreht wurde, sind ebenso stark enttäuscht. Lediglich einer berichtet mit einer größeren Antenne an der LTEBox von einer höheren Stabilität, aber da bin ich mir nicht so sicher.

Ich schicke das ganze Zeug nun wieder zurück und bleibe bei meinem Langsamen aber Stabilen DSL Lite Anschluss. Eventuell bessert sich das ganze ja nochmal durch einen weiteren Mast oder bessere Empfangstechnik.

25. Juni 2012

Werbung mit Sound

25. Juni 2012 - Geschrieben von Martin - 5 Kommentare

Kann es sein, dass in den letzten Tagen vermehrt Internet Werbung mit Sound auftaucht?
Andauernd kommt im Hintergrund irgendein Gelaber oder Werbetext.

Ich habe auf meinem Büro-PC logischerweise keinen Ad Blocker und benötige auch Flash, weshalb ich leider nichts dagegen machen kann. Einfach nervig.

14. Juni 2012

Hinter meinen Webapplikationen

14. Juni 2012 - Geschrieben von Martin - 2 Kommentare

Momentan mache ich eine Art Inventur, ich schaue was ich alles im Web habe, notiere mir Zugangsdaten, etc.

Heute bin ich beim Punkt Web- und Applikationshosting angelangt. Da es sicher für manchen Interessant ist, werde ich hier nun auflisten was denn eigentlich so alles hinter meinen ganzen Werbepräsenzen steckt.

10GB Webspace
…mit einer Datenbank und der Domain linux-doku.de
Dieser fungiert hauptsächlich als Daten und Mail Grab. Ich hab von den 10GB über 3GB belegt, davon wiederum 30% Mails, 60% gehen auf das Konto meines kleinen „ich muss mal schnell eine Datei temporär hochladen und vergesse sie mit 100 prozentiger Wahrscheinlichkeit zu löschen“ Services und der Rest ist dieser Blog sowie ein paar statische Kundenseiten, die auf Subdomains lauschen.

Der Webspace liegt bei einem Norwegischen Anbieter, allein aus dem Grund weil dass 2007 der günstigste Anbieter war. Ihr wisst ja, als Schüler hat man kein Geld für Hosting. Und da alles perfekt lief bin ich dort nun seit 5 Jahren Kunde.

„High Performance“ vServer
ausgestattet mit

  • 8 Kern CPU
  • 2x 4GB HD
  • 128MB Ram
  • 128MB SWAP

darauf laufen Lighttpd, MySQL, Exim, SVN, NodeJS, ProFTP, PHP5, Python äußerst stabil, trotz der doch verdammt langsamen Hardware. Ich habe alles bis ans absolute Maximum konfiguriert, es läuft nur was wirklich gebraucht wird und reserviert so wenig Speicher wie nur irgendwie möglich. Das beste, er swappt nicht mal!

Das absolute Maximum war als Resigame mit der Beta 2 Online war. Bei rund 100.000 Zugriffen am Tag ging er dann regelmäßig in die Knie, da ihm der Ram ausging und immerwieder die Festplatte volllief (zweiteres lag an einem Bug in MySQL, welcher die Log Dateien nicht mehr gelöscht hat *facepalm*)

Auf dem Server befinden sich momentan 5 Domains, darunter resigame.de, lttx.de und litotex.org. Dahinter laufen zwei Browsergames, Projektmanagement Portale, Backend Server für zwei Android Apps und ein Forum mit ca. 10.000 Beiträgen. Das ganze verteilt sich auf 2,3GB mit Log Dateien der letzten 4 Wochen.

Dann gab es bis vor kurzem noch einen
1GB Webspace
bei einem Deutschen Anbieter namens 2-1+2-1. Leider war der Server dort für seine ziemlich hohe Monatsmiete viel zu langsam, weshalb ich mich entschlossen habe die ganzen Seiten mit auf den vServer zu packen, was ich bis heute nicht bereut habe.

Ja gut und dann hatte ich noch bis vor kurzem einen Test Server zuhause mit

  • 1,6Ghz Intel Celeron
  • 512MB Ram
  • 60GB HD

darauf lief Ubuntu 8.04 mit der selben Software wie auf dem vServer oben – eigentlich ganz smooth. Ab und zu, war er sogar per DynDNS online, aber mit 9kb/s Upload war das ganze wirklich nur für äußerte Notfälle geeignet. Aber mittlerweile habe ich ein schnelles Notebook aufdem ich alles als Virutelle Maschine nebenher laufen lassen kann :)

13. Juni 2012

Resi ganz frisch

13. Juni 2012 - Geschrieben von Martin - Ein Kommentar

So sah unsere kleine Resi die letzten 3 Jahre aus

Und so sieht sie nun nach der Frischzellenkultur/Vektorisierung aus

ganz hübsch geworden die kleine. Da ich nun ein .svg habe kann ich sie natürlich beliebig skalieren. Die Poster sollten also nicht mehr lange auf sich warten lassen ;-)

9. Mai 2012

Ich höre sozial Musik

9. Mai 2012 - Geschrieben von Martin - 2 Kommentare

Schlagt mich, ich habe mich bei Spotify angemeldet. Mit meinem Facebook Account.

Ich weiß nicht was mich überkommen hat, ich wollte eigentlich nur mal den Dienst ansehen, als ich keine Möglichkeit fand mich ohne Facebook anzumelden hatte ich die Seite auch schon fast wieder geschlossen doch irgendwie habe ich mir dann doch einen Account gemacht. War es das verlockende Musik Angebot? War es die Picture Box mit Bildern meiner Freunde die ihren Facebook Accounts bereits mit Spotify gepaart haben? War es mein zweites Ich, das eiskalt mit Datenschutzrechtlich umstrittenen Firmen einen Vertrag schließt? Ich weiß es nicht.

Eins muss ich Spotify aber lassen, das Angebot ist aber echt erste Sahne. Kein Vergleich zu Simfy!